AMD Graphics Card Insallation Dependency Error

While I try to install the AMD driver I got the following dependency error.

--> Finished Dependency Resolution
Error: Package: xorg-x11-server-devel-1.19.3-11.el7.x86_64 (xorg)
           Requires: pixman-devel
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10()(64bit)
Error: Package: xorg-x11-server-Xdmx-1.19.3-11.el7.x86_64 (xorg)
           Requires: libXaw.so.7()(64bit)
Error: Package: 1:xorg-x11-drv-amdgpu-pro-1.2.99-410326.x86_64 (amd)
           Requires: X11_ABI_VIDEODRV = 20.0
Error: Package: xorg-x11-server-Xephyr-1.19.3-11.el7.x86_64 (xorg)
           Requires: libxcb-render-util.so.0()(64bit)

Error: Package: xorg-x11-server-devel-1.19.3-11.el7.x86_64 (xorg)
           Requires: pkgconfig(dri) >= 7.8.0
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_1.1)(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)

           Requires: libinput.so.10(LIBINPUT_0.14.0)(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput >= 0.21.0
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_0.12.0)(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_0.19.0)(64bit)
Error: Package: xorg-x11-xkb-extras-7.7-12.el7.x86_64 (xorg)
           Requires: libXaw.so.7()(64bit)
Error: Package: xorg-x11-xkb-utils-devel-7.7-12.el7.x86_64 (xorg)
           Requires: pkgconfig(x11)
Error: Package: xorg-x11-util-macros-1.19.0-3.el7.noarch (xorg)
           Requires: libtool
Error: Package: xorg-x11-server-devel-1.19.3-11.el7.x86_64 (xorg)
           Requires: pkgconfig(pciaccess) >= 0.12.901
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_1.3)(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_1.2)(64bit)
Error: Package: xorg-x11-server-devel-1.19.3-11.el7.x86_64 (xorg)
           Requires: pkgconfig(pixman-1) >= 0.27.2
Error: Package: 1:xorg-x11-drv-amdgpu-pro-1.2.99-410326.x86_64 (amd)
           Requires: X11_ABI_ANSIC = 0.4
Error: Package: xorg-x11-server-devel-1.19.3-11.el7.x86_64 (xorg)
           Requires: libpciaccess-devel
Error: Package: xorg-x11-server-Xephyr-1.19.3-11.el7.x86_64 (xorg)
           Requires: libxcb-keysyms.so.1()(64bit)
Error: Package: xorg-x11-resutils-7.5-13.el7.x86_64 (epel)
           Requires: libXaw.so.7()(64bit)
Error: Package: xorg-x11-util-macros-1.19.0-3.el7.noarch (xorg)
           Requires: automake
Error: Package: xorg-x11-server-Xephyr-1.19.3-11.el7.x86_64 (xorg)
           Requires: libxcb-image.so.0()(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_1.5)(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_1.4)(64bit)
Error: Package: xorg-x11-server-Xephyr-1.19.3-11.el7.x86_64 (xorg)
           Requires: libxcb-icccm.so.4()(64bit)
Error: Package: xorg-x11-xkb-utils-devel-7.7-12.el7.x86_64 (xorg)
           Requires: pkgconfig(xkbfile)
Error: Package: xorg-x11-util-macros-1.19.0-3.el7.noarch (xorg)
           Requires: autoconf
Error: Package: xorg-x11-apps-7.7-7.el7.x86_64 (xorg)
           Requires: libXaw.so.7()(64bit)
Error: Package: xorg-x11-drv-libinput-0.25.0-2.el7.x86_64 (xorg)
           Requires: libinput.so.10(LIBINPUT_0.21.0)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@blrpc660 yum.repos.d]#
Finall I can easily install using following method. At the bottom of the driver download page I have found the following link. Linux Driver Install Without XServer Libraries -> http://support.amd.com/en-us/kb-articles/Pages/XServerLessDriver.aspx 

Amd driver dependency error

0 comments: