How to Resolve Error message configure: error: no acceptable C compiler found in $PATH

When I try to install vert- manager I got the following error message.
The Error message says Linux compiler it is not find or accept gcc compiler.
[bash@r-n-cluster2 virt-manager-0.8.4]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether NLS is requested... yes
checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/bash/Desktop/virt-manager-0.8.4':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


So I run the following command to check whether I install gcc compiler or not
[bash@r-n-cluster2 virt-manager-0.8.4]# gcc
bash: gcc: command not found

So that I confirm I am not install gcc compiler

Then I install gcc compiler through Yum.
[bash@r-n-cluster2 virt-manager-0.8.4]# yum install gcc*

===========================================================================
 Package                 Arch       Version          Repository        Size 
===========================================================================
Installing:
 gcc                     i386       4.1.2-14.el5     base              5.2 M
 gcc-c++                 i386       4.1.2-14.el5     base              3.4 M
 gcc-gfortran            i386       4.1.2-14.el5     base              3.1 M
 gcc-gnat                i386       4.1.2-14.el5     base               11 M
 gcc-java                i386       4.1.2-14.el5     base              2.9 M
 gcc-objc                i386       4.1.2-14.el5     base              2.5 M
 gcc-objc++              i386       4.1.2-14.el5     base              2.7 M
Installing for dependencies:
 glibc-devel             i386       2.5-18           base              2.0 M
 glibc-headers           i386       2.5-18           base              609 k
 gmp                     i386       4.1.4-10.el5     base              665 k
 kernel-headers          i386       2.6.18-53.el5    base              779 k
 libgcj-devel            i386       4.1.2-14.el5     base              1.4 M
 libgfortran             i386       4.1.2-14.el5     base              224 k
 libgnat                 i386       4.1.2-14.el5     base              982 k
 libgomp                 i386       4.1.2-14.el5     base               76 k
 libobjc                 i386       4.1.2-14.el5     base               95 k
 libstdc++-devel         i386       4.1.2-14.el5     base              9.4 M
 zlib-devel              i386       1.2.3-3          base              100 k

Then I try to compiler the vert- mangaer package 
it is install usefully without any issue.
configure: error: in `/bash/Desktop/virt-manager-0.8.4':
configure: error: no acceptable C compiler found in $PATH

Related post